Help - Poor running after carb rebuild

Forum rules
Please can you post items for sale or wanted in the correct For Sale section. Items / bikes for sale here will be removed without warning. Reasons for this are in the FAQ. Thanks
moforockband
Familiar Member
Reactions:
Posts: 299
Joined: Wed Jun 03, 2015 9:41 am
Bike owned: GK73a SP CRM250 mk3
Re: Help - Poor running after carb rebuild

Post by moforockband » Mon Aug 27, 2018 7:33 pm

Suzuki416 wrote:
Mon Aug 20, 2018 9:17 pm
Don't feel bad - I cleaned my wifes CBR400rr fuel tank, replaced the filters & then had to remove & strip the carbs 3 times - due to crap in the lines...
It just happens & you get better at doing it each time - lol

Glad to hear its fixed.
It's definitely worth putting a metal cleanable inline fuel filter, as the fuel socks on the tap still let enough crap through to block pilot jets etc. Pulling the carbs off all the time sucks b***s :down:

bluesmokeracer
Settled in member
Reactions:
Posts: 16
Joined: Sat Jul 21, 2018 8:19 am
Re: Help - Poor running after carb rebuild

Post by bluesmokeracer » Sat Sep 08, 2018 8:25 am

Good call on the filter. Willl order.

Bike running beautifully after all my labours! Runs cleanly and pulls well.

Lovely engines on these GSXR400 - creamy smooth low down.

Now tucking into the other 400 we own (a 1992 model). Has developed a low range misfire - suspect coil - plugs 1 and 4 sooty. Have just received a replacement coil so will be fitting today ....

Thx


Post Reply

Return to “GSXR - Workshop”