GK76a No spark.

Forum rules
Please can you post items for sale or wanted in the correct For Sale section. Items / bikes for sale here will be removed without warning. Reasons for this are in the FAQ. Thanks
Post Reply
Oldbiker
Settled in member
Reactions:
Posts: 3
Joined: Mon May 07, 2018 5:31 pm
GK76a No spark.

Post by Oldbiker » Mon May 07, 2018 5:41 pm

Hi guys,
My son bought a GSXR400 gk76a a bit back and almost from day 1 was difficult to start. After a couple of months it wouldn't start at all. Turns out there is no spark at the plugs. We changed the CDI, then the pickup coil, still nothing. These were used parts so we are not even sure that they are good ones. We did test the resistance of the pickup on the bike and got zero. The "new" one does have good resistance.
Now the nice weather is here he is itching to get the bike sorted.
anyone have any suggestions what to check next? Or does anyone have any good used parts we could buy?
Ta in advance,
Gary.

moforockband
Familiar Member
Reactions:
Posts: 299
Joined: Wed Jun 03, 2015 9:41 am
Bike owned: GK73a SP CRM250 mk3
Re: GK76a No spark.

Post by moforockband » Mon May 07, 2018 10:12 pm

viewtopic.php?t=39983 Have a look at the wiring diagram here.
I would check the neutral feed/sensor, as it feeds the cdi indirectly, and will give the symptoms. There's a relay to check also. It's a bit blurry though the diagram! I think the 73a wiring is similar and clearer.
I suspect your coils/pulse coil are OK.
Be mindful that the cdi must match the rotor trigger, in case you start swapping cdi's and get confused.

Oldbiker
Settled in member
Reactions:
Posts: 3
Joined: Mon May 07, 2018 5:31 pm
Re: GK76a No spark.

Post by Oldbiker » Tue May 08, 2018 3:36 pm

Thanks Moforockband,
I never thought of the neutral sensor. I'm guessing it needs to be checked for continuity? And the relay, check current is going through and it's switching?
Strange thing is, although it won't spark while turning over, wait a few seconds with ignition still on and Hey Presto - a single spark!
I'll let you know how we get on. :?

Oldbiker
Settled in member
Reactions:
Posts: 3
Joined: Mon May 07, 2018 5:31 pm
Re: GK76a No spark.

Post by Oldbiker » Tue May 15, 2018 9:02 am

Ok, bike is now running!
Seems as the neutral light/sensor could well have been the culprit.
disconnected all the connections/relay and gave it all a good squirt with contact cleaner then a blast with air to dry it off. Immediately on ignition and gearchange into and out of neutral there was a healthy click from the relay that I had not noticed before. Turned it over and spark!!
Many thanks!!!

moforockband
Familiar Member
Reactions:
Posts: 299
Joined: Wed Jun 03, 2015 9:41 am
Bike owned: GK73a SP CRM250 mk3
Re: GK76a No spark.

Post by moforockband » Tue May 15, 2018 3:22 pm

Yep, thinking about it, that click must be heard every time you turn the ignition. Same on the 73a bikes.
Glad it's running.


Post Reply

Return to “GSXR - Workshop”